当前位置: 首页 > 服务器 > 正文

PHP5.4 Zend支持组件Zend Guard Loader (Runtime for PHP 5.4) 发布,安装教程

PHP5.4发布至今一年多,但Zend组件(Zend Optimizer / Zend Guard Loader)却一直不支持,很多像我一样升级了PHP5.4的朋友跟我一样郁闷过吧,以前貌似只能重新配置PHP。。。像我这种用LNMP之类套件的貌似只能全部重新搭建生产环境吧。

最近Zend发布了Zend Guard Loader (Runtime for PHP 5.4),在PHP5.5(官方说自带支持Zend Optimizer)出来之前,我们可以很简单的有Zend组件支持PHP5.4啦,好激动啊,不纠结了,上教程:

 

1.下载Zend Guard Loader (Runtime for PHP 5.4)

根据32位或64位选择对应的系统版本,官方下载地址:http://www.zend.com/en/products/guard/downloads

下载需要注册Zend网站的,懒得注册的直接在我这下载就可以咯:

Zend Guard Loader (Runtime for PHP 5.4)(32 bit) (379.9 KiB)

Zend Guard Loader (Runtime for PHP 5.4)(64 bit) (416.3 KiB)

 

2.安装 Zend Guard Loader

解压后将 ZendGuardLoader.so 上传到服务器 /usr/local/zend/ 目录,我的LNMP自带的有原先的PHP5.3版本的组件,替换即可;

 

3.配置 Zend Guard Loader

编辑php.ini(/usr/local/php/etc )文件,在最后位置添加以下内容:

 

[Zend Guard]

zend_extension=/usr/local/zend/ZendGuardLoader.so

; Enables loading encoded scripts. The default value is On

zend_loader.enable=1

; Optional: following lines can be added your php.ini file for ZendGuardLoader configuration

zend_loader.disable_licensing=0

zend_loader.obfuscation_level_support=3

zend_loader.license_path=

 

4.重启

/root/lnmp restart

至此,Zend Guard Loader (Runtime for PHP 5.4)安装完成,我们可以在 phpinfo 和 探针 看到如下成功安装信息。

本文固定链接: http://www.cuijinlin.com/2013/05/zend-guard-loader-runtime-for-php-5-4.html | 崔金林的博客

该日志由 Nothing! 于2013年05月21日发表在 服务器 分类下, 你可以发表评论,并在保留原文地址及作者的情况下引用到你的网站或博客。
原创文章转载请注明: PHP5.4 Zend支持组件Zend Guard Loader (Runtime for PHP 5.4) 发布,安装教程 | 崔金林的博客
关键字: ,
  1. 我发现一个问题,zend_loader.obfuscation_level_support=3,但是phpinfo后,一直显示为0也是混淆设置3,不起作用,你是如何解决的啊?

  2. 问下在windows怎么安装啊?想使用shopex,但是要求安装zend

  3. Pingback: 请教一个 php5.4 安装Zend Optimizer 的问题 - PHP - 开发者第1092197个问答

  4. 试过了 wampserver Apache : 2.4.4 MySQL : 5.6.12 PHP : 5.4.16 PHPMyAdmin : 4.0.4 SqlBuddy : 1.3.3 XDebug : 2.2.3 这个用你的办法不行 Zend Guard Loader 根本不显示

  5. 哈,升级了好啊,虽然还有很多不支持PHP5.4,Zend一套年费600美元也确实够贵的。。。